User login

Navigation

You are here

MPI errors on a linux cluster (ABAQUS/Explicit)

Hello everybody,

i try to perform a 2D orthogonal cutting simulation using the Johnson-Cook damage model in ABAQUS/Explicit. When simulated on my desktop PC (AMD Phenom quad core processor, Windows Vista 64bit), the simulation runs successfully. But if  I try to run the simulation on a linux cluster, it ends with error messages related to HP-MPI. Moreover, if I run a 3D drilling simulation on the cluster, it runs successfully with no errors.

I use ABAQUS 6.7.5, CPE4R elements. 

Example of error messages from *.log file:

ABAQUS/Explicit checked out 15 tokens.
<0 out of 15 licenses remain available>.
forrtl: error (75): floating point exception
MPI Application rank 10 killed before MPI_Finalize() with signal 6
forrtl: error (78): process killed (SIGTERM)
forrtl: error (78): process killed (SIGTERM)
forrtl: error (78): process killed (SIGTERM)
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source
libirc.so 00002B1624CA2CEA Unknown Unknown Unknown
libirc.so 00002B1624C9D606 Unknown Unknown Unknown
libifcoremt.so.5 00002B16256BBD7B Unknown Unknown Unknown
forrtl: severe (174): SIGSEGV, segmentation fault occurred
Image PC Routine Line Source

Floating point exception does not occur in every simulation (I think it occurs only when a mesh i denser, i.e. 0.02 mm), MPI Application rank errors occurs in every simulation (except 3D simulation as mentioned above). 

Cluster configuration is as follows:

OS: CentOS release 5.5 (Final) 64bit Kernel 2.6.18-194.3.1.el5 x86_64
HW: 2 x IBM blade HS21 (Type 8853) in BladeCenter-H
HW blade: 2 x Intel(R) Xeon(R) CPU E5440 @ 2.83GHz 8 GB RAM
Interconnect: 1Gbit ethernet
 

Could you post any advice?

Regards, M. Madaj. 

Well, I found that it's related to surface to surface contacts somehow. But I don't know how. 

I have the same problem like you describe. How did you solve it?

I am post graduate student trying to simulate the orthogonal cutting process. I am stuck up in the chip separation. Please can you help me with the input file. It will be helpful for me to go a long way in the project. I wil be grateful for your help in this regard. Please can you send me your input file of turning process to prakashkmuthu@gmail.com.

 

Looking forward for your reply.

 

regrds,

prakash 

Subscribe to Comments for "MPI errors on a linux cluster (ABAQUS/Explicit)"

Recent comments

More comments

Syndicate

Subscribe to Syndicate