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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialGoals
• The purpose of this tutorial is to introduce the user to good

techniques for accurately modelling flow in high speed external
aerodynamic applications.

• Transonic flow will be modelled over a NACA 0012 airfoil for which
experimental data has been published, so that a comparison can be
made.

• The flow to be considered is compressible and turbulent.p

• The solver used is the density based implicit solver, which gives
good results for high speed compressible flowsgood results for high speed compressible flows.

• The tutorial is carried out using ANSYS FLUENT and CFD Post from
within Workbench but it could also be completed in standalone
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within Workbench, but it could also be completed in standalone
mode.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialStart a workbench project
• Launch Workbench
– START > all programs > ANSYS 13.0 > Workbench

• Save the new project as ‘naca0012.wbpj’ in your chosen workingp j pj y g
directory.

Save AsSave As
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCreate folder structure and user files area
• Saving the project immediately creates a folder structure which

workbench will automatically manage.

• Included in the new folder structure is a ‘user_files’ area where
external files can be placed. This means that these files will be
archived with the project and not lost if the project is relocated.

• For this workshop, a mesh file has already been generated and
supplied. Experimental result files and case comparison files havepp p p
also been provided. Copy them all into the user_files folder:

working directory > naca0012_files > user_files >
NACA0012.msh
t t d t ttest-data-top.xy
test-data-bottom.xy
mach_0.5_comparison.cas.gz and mach_0.5_comparison.dat.gz
mach_0.7_converged.cas.gz and mach_0.7_converged.dat.gz
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• Shortly we will be importing the mesh file into our Fluent simulation.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialView your file locations
• You can easily view the location of the files that are associated with

your project (View > Files).
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPick a FLUENT system from the toolbox
• Double-click or drag a Fluid Flow (FLUENT) analysis system from

your toolbox into your project workspace.
• If you wish, rename the FLUENT analysis, e.g. Mach_0.7

Double-Click
or Drag into your workspace
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialImport the supplied mesh file
• Import the supplied FLUENT mesh file (naca0012.msh)
– Right click on Mesh (cell A3) and select ‘Import Mesh File’
– Browse to the mesh file which was placed into the user_files folder

Right mouse button (RMB)

Import Mesh File

browse to:

workdir > naca0012_files
> user_files
> naca0012.msh
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialImport the supplied mesh file
• Note that because we have imported a mesh file the geometry tab is 

automatically removed as it is not needed.
• Note also that the mesh cell now has a green tick to indicate that the 

this part of the analysis system is completed and up-to-date.
• The next cell is the setup cell, used to open FLUENT and setup the 

case so that it is ready to run.
• Right-click > edit (or just double-click the setup cell).
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialLaunch FLUENT to set up the case
• The FLUENT launcher will start.
– Note that ‘2D’ has automatically been selected based on the mesh file
– Keep the default options for everything else, click OK

For this workshop single 
precision (the default) is used.

Double precision may yield 
more accurate drag prediction, 
and is recommended in real 
cases.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialLaunch FLUENT to set up the case
• FLUENT will launch in a new window.
• The mesh will automatically read in and display (can be disabled).
• A settings file will automatically be written to the Workbench project.A settings file will automatically be written to the Workbench project.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialExamine the mesh
• Zoom in and examine the mesh.

• The maximum aspect ratio in this mesh is quite high, as will be examined
shortly.

• This is a result of placing the first grid point in the viscous sublayer close
to the airfoil wall surface, for maximum accuracy in the turbulence model.

• However, very long thin (stretched) cells can lead to problems, so we
need to proceed with some checksneed to proceed with some checks.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialScale the mesh
• First of all, it is always important to check the scaling of the mesh, 

particularly when it has been imported from outside of workbench.
• Select General > Mesh > Scale  and check the domain extents.
• In this case the domain extents are correct. 
• If they are not, scale the mesh before proceeding any further!
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (general errors)
• Check the mesh for errors: General > Mesh > Check
– Review the text window output and check there are no errors
– In particular make sure that the minimum cell volume is not negativep g
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (aspect ratio)
• In this case there are no errors reported with the mesh.
• Note, however, that we do have a warning which is a result of the 

high aspect ratio cells within the boundary layer near the airfoil wall.g p y y
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (aspect ratio)
• Report the mesh quality statistics:
– General > Mesh > Report Quality
– Note the maximum aspect ratio is high at 2655p g
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (aspect ratio)
• As a guide, the cell aspect ratio should be around 5 or less in the

main region of the mesh (away from the boundary layer).
• However, it is usual to have much higher aspect ratio cells than this, g p

in the boundary layer, up to around 100.
• In this case, the maximum aspect ratio in the boundary layer is much

higher than this, but the mesh was designed in this way due to theg , g y
need for very low Y+ values. Away from the boundary layer the
maximum aspect ratio is around 5.

• For this special case the high maximum aspect ratio is justified.p g p j
• Not all cases require such a well resolved boundary layer mesh.
• Be aware that such high aspect ratio cells can give problems in the

solver calculations near to the wall, hence the warning when thesolver calculations near to the wall, hence the warning when the
mesh quality metrics are reported.

• It is necessary to check that the solver is computing the wall distance
correctly, as this will be used in the turbulence model when we
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correctly, as this will be used in the turbulence model when we
switch it on.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (wall distance check)
• FLUENT suggests a method to check the wall distances that are

calculated by the solver.

• The cells need some (any) data before we can post-process any
variables, including wall distances, so initialize the flow:
– default values are fine at this stageg

• Solution Initialization > Initialize
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (wall distance check)
• Now we can use the contour plot facility to report the wall distances.
• Graphics & Animations > Contours > Set Up
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (wall distance check)
• Select Contours of Mesh > Cell Wall Distance
• Choose the airfoil wall surfaces (airfoil_lower and airfoil_upper)
• Deselect global range (report the local range of these surfaces only)Deselect global range (report the local range of these surfaces only)

Click ‘Compute’

The minimum computed cell wall
distance is 8.2e-07 m

The maximum computed cell wall
distance is 7.1e-06 m

For the airfoil wall surfaces theseFor the airfoil wall surfaces these
are as expected from the mesh
design, so we can proceed with
our normal set up.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (some notes on Y+)
• Y+  is the non-dimensional normal distance from the first grid point 

(the wall-adjacent cell center) to the wall.

• If the first grid point is placed within the viscous sublayer (the near-
wall region where y+ <= 5), the turbulence model's enhanced wall 
treatment (EWT) option should be chosen. When using EWT, the ( ) p g ,
intention is to integrate governing equations directly to the wall 
without using the Universal Law of The Wall for turbulence.

• The aspect ratio could be reduced, while keeping the same Y+ value:
– by keeping the same first cell distance
– and increasing the number of nodes along the wall surfaceand increasing the number of nodes along the wall surface

• reduces the length of cells for a given height so will reduce the aspect ratio
• this would significantly increase the overall cell count
• for this tutorial, the cell count has been kept low while maintaining low Y+
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (some notes on Y+)
• The aspect ratio could also be reduced, while increasing Y+ value:

– by increasing the normal distance of the first grid point from the wall to give y g g p g
Y+ values of between 30 and 300.

– This is the valid range of y+ for using the wall functions approach.

– Avoid placing the first grid so that 5 < y+ < 30, which is called the buffer layer. 
(Due to the large variation of various turbulence source terms in the buffer 
layer no existing models can handle the wall treatment well if the first gridslayer, no existing models can handle the wall treatment well if the first grids 
lie in this region.)
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (orthogonal quality)
• In addition to maximum aspect ratio, the minimum orthogonal quality 

is also reported:
– 1 is the best quality, 0 is the worst quality.

• For this mesh, the minimum value is reported as 3.96e-02 which is 
again the result of highly stretched cells in the boundary layer.g g y y y

• This can be examined further using the contour panel again: 

– Contours of Mesh > Orthogonal Quality

• Deselect all surfaces• Deselect all surfaces
• Select global range
• Select Filled
• Display
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (orthogonal quality)
• Most cells are good quality, many are around 1 (shown in red)
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (orthogonal quality)
• Zoom in to the boundary layer cells near the airfoil wall, these cells 

are blue (low orthogonal quality) due to the stretched cells.
• In particular this can be seen where they meet at the trailing edge.p y g g
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCheck the mesh (proceed)
• High aspect ratio cells and low orthogonal quality cells have been 

identified in the mesh.
– Both are located in the stretched boundary layer cells.

• This is acceptable in this airfoil drag-prediction case, where low Y+ 
values can lead to high aspect ratio cells. g p
– More grid points along the airfoil wall surfaces would reduce the aspect 

ratio, but increase the overall mesh size. 

• The cell wall distance computed by the solver, and needed for the 
turbulence model, has been checked.

• Proceed with this mesh and set up the case.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Choose the solver and models
• Select the steady-state density-based solver:
– General > Solver > Type > select ‘Density-Based’
– General > Solver > Time > steady (default)
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Choose the solver and models
• Turn on the energy equation.  
– Models > Energy > Edit > Toggle ‘On’ 
– This is needed because the flow is compressible and temperature will be 

variable. 
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Choose the solver and models
• Select the turbulence model to be used:

• Models > Viscous > Edit
• Choose k-omega (2-eqn)
• Select SST, then OK
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Define Materials
• Constant density air is the default fluid.
– This must be modified for compressible flow.

• Materials > Fluid > Air > ‘Create/Edit’

– For Density, select ‘Ideal Gas’y,

– For Viscosity, select ‘Sutherland’

• Accept the default settings for the Three Coefficient Method

• The Sutherland law for viscosity is well suited for high-speed compressible 
flowflow.

– For simplicity, we will leave Cp and Thermal Conductivity as constant. 
– Ideally, in high speed compressible flow modeling, these should be temperature
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Ideally, in high speed compressible flow modeling, these should be temperature 
dependent as well.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Define Materials

Click ‘Change/Create’ g

Close the materials panel.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Assign Materials
• Check that ‘air’ is assigned to the cell zone ‘fluid’
• Cell Zone Conditions > Zone > ‘fluid’ > edit 
– In this case there is only one cell zone (with the default name of fluid)y ( )
– In this case there is also only one material (air, which has been modified)
– There can be multiple zones with user-specified names and multiple 

materials if required
• There is nothing else to assign to the fluid cell zone for this case
– Other tabs are enabled when the corresponding options are selected
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Operating Conditions
• Cell Zone Conditions > Operating Conditions
– Note: can also be accessed from the boundary conditions panel

• Absolute pressure = operating pressure + gauge pressurep p g p g g p
– For incompressible flows (where pressure changes are relatively small)

it is normal to specify a large operating pressure and let the solver work
with smaller ‘gauge’ pressures (FLUENT input/output values), to reduce

d ffround-off errors.
– For compressible flows, the solver needs to use the absolute values in

the calculation anyway, so numerically this makes no difference.

Therefore, with compressible flows, it is sometimes 
convenient to set to operating pressure to zero, and 
input/output ‘absolute’ pressures.

This is simply a user preference Other times it may beThis is simply a user preference. Other times it may be 
convenient to set a bulk flow operating pressure.

The main thing to remember is that whatever operating 
pressure is set, this will be added to any gauge input 
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pressures.
Set Operating Pressure to 0 Pa 



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• Boundary Conditions > Zone > select ‘airfoil_lower’
• Check that the boundary zone type is set to ‘wall’
– If not, use the drop down list to change!, p g

• Edit > Momentum Tab
– leave the default settings which correspond to a stationary wall (relative

to the fluid zone) with a no-slip condition.) p
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• Thermal Tab
– Remember that the energy equation is switched on so thermal boundary

conditions must be applied.
– Leave the default setting (zero heat flux) which corresponds to an

adiabatic wall
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• Boundary Conditions > Zone > ‘airfoil_upper’

– Check that the boundary zone type is set to ‘wall’y yp
• If not, use the drop down list to change!

– Edit > Momentum Tab and Thermal Tab
• Repeat as for airfoil_lower (no-slip, adiabatic)

• Boundary Conditions > Zone > ‘farfield’

– Check that the boundary zone type is set to ‘pressure-far-field’y yp p
• If not, use the drop down list to change!

– Edit > Momentum Tab and Thermal Tab
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• See next slides



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• Set the far field boundary conditions:

– The pressure-far-field boundary is applicable only when using the ideal-gas law. 
– It is important to place the far-field boundary far enough from the object of 

interest.
• For example, in lifting airfoil calculations, it is not uncommon for the far-field boundary to 

be a circle with a radius of 20 chord lengths. 

– This workshop will compare CFD with wind-tunnel test data.p p
– We need to input the static pressure at a far-field boundary.
– We can calculate this from the total pressure, which

was atmospheric at 101325 Pa in the test.
We have already set the operating pressure to zero 2
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– We have already set the operating pressure to zero, 
so we are now working in absolute pressure values.
Hence the ‘gauge’ static pressure input will be equal 
to the ‘absolute’ static pressure value, which we will

pressurestatic
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calculate to be 73048 Pa, for a Mach number of 0.7

– On the ‘Momentum’ tab
• set the gauge static pressure to 73048 Pa 38711
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• set the Mach Number to 0.7
Pa 73048

3871.1
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∴

p
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• The angle of attack (α) in this case is 1.55 deg. The x-component of the flow

is cos α and the y-component is sin α.
– Set the flow direction components as shown

It is common practice to adjust the numerical α from the experimental α in order to match the lift obtained in– It is common practice to adjust the numerical α from the experimental α in order to match the lift obtained in
the wind tunnel, and then to determine the drag associated with this lift. This adjustment of α is carried out to
counter the effects of the wind tunnel enclosure.

• Set reasonable boundary conditions 
for the far field turbulence:

• Select ‘Intensity and Viscosity Ratio’
• Set the intensity to 1%
• Set the viscosity ratio to 1y
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Boundary Conditions
• Select the thermal tab.
– The wind tunnel operating conditions for validation test data give the 

total temperature as T0 = 311 K
– We can therefore calculate the static temperature to be 283.24 K

2
11 20 ⎟
⎠
⎞

⎜
⎝
⎛ −γ

+= M
T
T

where

2
⎟
⎠

⎜
⎝T

airfor4.1
etemperaturstatic 

K 311  etemperatur total0

=γ
=

==

T
T

K 24.283so and  098.1

7.0  number Mach
airfor4.1

0 ==∴

==
γ

T
T
T

M

WS2-38
ANSYS, Inc. Proprietary
© 2010 ANSYS, Inc.  All rights reserved.

Release 13.0
December 2010

T



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Reference Values
• Set the reference values
– These are not used to compute the flow solution, but they are used to 

report coefficients, such as Cp.
• Use the free-stream as a reference condition.
Select ‘compute from farfield’ in the drop down list.

Reference values for velocity, density, temperature, etc. 
will update from the free-stream values.

S t th f ll i t t h d l th f 1Set the following to represent a chord length of 1m 
with unit depth:

reference length = 1m
reference depth = 1mreference depth   1m
reference area     = 1m2

These are not updated from the farfield conditions, but 
the defaults happen to be 1 already.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Methods
• The CFD model itself is now defined, but the solver settings need to be 

modified. These dictate how fast, stable and accurate (for the given mesh 
and model choices) the solution will be.

• Solution Methods > 

– Keep the default settings for implicit formulation and Roe-FDS flux type.p g p yp
• The explicit formulation is only normally used for cases where the characteristic time scale 

is of the same order as the acoustic time scale, for example the propagation of high Mach 
number shock waves.

• The implicit formulation is more stable and can be driven much harder to reach a 
converged solution in less time.

– Change the gradient method to Green-Gauss Node Based.
Thi i li htl t ti ll i th th th th d b t i• This is slightly more computationally expensive than the other methods but is 
more accurate.

– Select Second Order Upwind for flow and turbulence discretization
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– Select Second Order Upwind for flow and turbulence discretization.
• To accurately predict drag, the default 1st order schemes are not sufficient.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Methods
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Controls
• The Courant number (CFL) determines the internal time step and 

affects the solution speed and stability.
– The default CFL for the density-based implicit formulation is 5.0.

– It is often possible to increase the CFL to 10, 20, 100, or even higher, depending on the stability 
of the solution. It may be that a lower CFL is required during startup (when changes in the 
solution are highly nonlinear), but it can be increased as the solution progresses. 

As we will be using automatic
‘solution steering’ the choice of CFLsolution steering , the choice of CFL
at this stage is not important for this
case.

Keep the default under relaxationKeep the default under-relaxation
factors (URFs) for the uncoupled
parameters.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Monitors
• Set up residual monitors so that convergence can be monitored
– Monitors > Residuals > Edit
– Make sure ‘Plot’ is on
– Turn off convergence targets by setting the criterion to ‘none’. 

• This means that the calculation will not stop at pre-defined convergence 
criteria, but residual convergence can still be plotted.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Monitors
• Set up a monitor for the drag coefficient on the airfoil.

• Select both wall zones and toggle on ‘Print’, ‘Plot’ and ‘Write’.

– Remember that α is 1.55° so we need to use the force vector as shown.
• Lift and drag are defined (perpendicular and parallel respectively) relative to the free-

stream flow direction, not the airfoil.

You can specify
which window
FLUENT ses toFLUENT uses to
display plots. For
now, accept the
defaults.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Monitors
• Set up a monitor for the lift coefficient on the airfoil in the same way.

– Note the force vector is different to the drag monitor

•
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Initialization
• Initialize the flow field based on the farfield boundary:
– Solution Initialization > Compute from > farfield

There will be existing data 
from the earlier initialization 
used for checking the cell 
wall distances, etc.

– ‘Initialize’

Click OK when prompted to 
discard the old data and 
overwrite with the new flow 
data.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Case Check
• Run Calculation > Check Case
– Check the case file and make sure there are no reported issues.

– Any potential problems or reminders associated with the case setup willy p p p
be raised in the case check panel.

– In this case, in the solver tab, there is a recommendation to check the
reference values for the force monitors.
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• Since we have already set these we can ignore this reminder.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Steering
• Solution Steering
– uses ‘Full-Multi-Grid (FMG) Initialization’ which will compute a quick,

simplified solution based on a number of coarse sub-grids. This quick
l ti h l t t t bl t ti i t d i b tt ‘i iti lsolution can help to get a stable starting point and is a better ‘initial

guess’ for the main calculation
– employs robust first order discretization in the early-stages of the main

computation then blends to the more accurate second order schemes ascomputation, then blends to the more accurate second order schemes as
the solution stabilizes

– gradually ramps up the CFL in line with stability

• Run Calculation >
– Toggle on Solution Steering

Change the flow type to ‘transonic’– Change the flow type to transonic
–More settings > reduce the Explicit Under-Relaxation Factor to 0.5

• this is recommended for second order discretization and should make the solution more
stable
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialCase Setup: Solution Steering
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialRun Calculation
• Set three graphics windows
– For the residual, lift and drag monitors

• File > Save Project!

• Run Calculation >• Run Calculation >
– Set the number of iterations to 1000
– Press ‘Calculate’.

– Note: It is good practice to run and then check the FMG
first (by setting the main iteration number to zero and
then pressing calculate) before starting the main
calculation iterations. The FMG calculation can diverge
just as the main calculation can do. Check for non-j
physical velocities, temperatures, etc. For this workshop,
the FMG has already been checked.

– The calculation should take about 15 minutes. Time for a
coffee? If you can’t wait, the converged case and data
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y , g
files can be read from your user_files folder.



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialRun Calculation
• After 1000 iterations the calculation has converged.

• Note that the CFL has been steadily ramped up during the calculation by the 
solution steering algorithm. This can be seen in the CFL value displayed and 
the effect on the residuals is also evident.

– The residuals have converged to low values and the drag and lift 
monitors are no longer changing. 
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Compare the predicted Cl and Cd against the experimental values.

• From Reference 1, Cl = 0.241 and Cd = 0.0079From Reference 1, Cl  0.241 and Cd  0.0079

• The CFD solution predicts Cl = 0.241 and Cd = 0.0081

• Good agreement can be seen.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Examine the contours of static pressure
– Graphics and Animations > Contours
– Turn off ‘Filled’ to just display the 

contour lines.
– Turn on ‘Filled’, display again.

• Note the high static pressure at the
nose, and low pressure on the uppernose, and low pressure on the upper
(suction) surface

WS2-53
ANSYS, Inc. Proprietary
© 2010 ANSYS, Inc.  All rights reserved.

Release 13.0
December 2010



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Examine the contours of Mach Number
– notice that the flow is now locally supersonic (Mach Number > 1)
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Plot the pressure coefficient (Cp) along the upper and lower airfoil

surfaces.

• Results > Plots > XY Plot > Set Up
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Now load the test Cp data for comparison
• Load File > browse to the .xy files placed earlier in the user_files

folder
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• Once loaded, plot the CFD and experimental Cp results together.
• A good agreement can be seen.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [FLUENT]
• In order to obtain a good drag prediction, and for the turbulence 

model to work effectively, the mesh is well resolved near to the wall, 
such that the first grid point is located in the viscous sub-layer, with 

f ( )Y+ of 5 or less (ideally around 1).
• XY Plot > Turbulence > Wall Y Plus > along both of the airfoil walls.
• We can see that Y+ is around 2.5 for much of the surface, max Y+ < 3
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• File > Save Project (save the project from the FLUENT file menu)
• File > Close FLUENT
• Additional post-processing will now be performed in CFD Post.
• Return to the Workbench Project window.
• Click on ‘Refresh Project’ and notice the Results cell update.
• Right click the Results cell and select Edit. This will launch CFD Post. 

WS2-59
ANSYS, Inc. Proprietary
© 2010 ANSYS, Inc.  All rights reserved.

Release 13.0
December 2010



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• CFD Post works in 3D, so a unit thickness will be automatically be

added to the 2D airfoil, with symmetry side boundaries.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• Insert a new Contour and accept the default name  ‘Contour 1’
– Insert > Contour (or use the icon)

• In the details panel, choose an existing location: ‘symmetry 1’p , g y y
• Choose the variable to be ‘Pressure’ then click Apply 

Choose all domains, so that the contour 
will apply to both cases when a pp y
comparison is carried out shortly.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]

• Click on the Z-axis in the 
coordinate system triad to 

i t i th XY lorient in the XY plane. 

• To zoom in:
left mouse button
(or mouse wheel)

• To pan:To pan:
<CTRL> + middle mouse 

O th t lb i t
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• Or use the toolbar icons to 
switch between modes



WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• A useful feature in CFD Post is the ability to load multiple sets of CFD 

and/or test data, and to then compare any two of them together to 
generate a difference plot.

• File > Load Results > browse to the user_files folder
– Load ‘mach_0.5_comparison.dat.gz’
– Click OK if an information dialog box appears
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• Make sure that two windows are open and that each case is displayed

in a different window.
• Lock the views so they are synchronised.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialPost Processing [CFD POST]
• Double-click ‘Case Comparison’ to open the details panel.
• Activate, and select the cases to compare (there are only two here).
• Apply. The pressure difference between the two cases is plotted.Apply. The pressure difference between the two cases is plotted.
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialSummary
• In this workshop ANSYS FLUENT has been used within a workbench

project to compute the transonic, compressible flow over a naca0012
airfoil.

• The implicit density based solver with solution steering was
employed.

• Computed results have been compared to published experimental
data and good agreement was achieved.g g

• A case comparison has been carried out within CFD Post to compare
the pressure fields at Mach 0 5 and Mach 0 7the pressure fields at Mach 0.5 and Mach 0.7
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WS2: Transonic flow over NACA0012 Airfoil

Customer Training MaterialReferences
• T.J. Coakley, “Numerical Simulation of Viscous Transonic Airfoil

Flows,” NASA Ames Research Center, AIAA-87-0416, 1987.

• C.D. Harris, “Two-Dimensional Aerodynamic Characteristics of the
NACA 0012 Airfoil in the Langley 8-foot Transonic Pressure Tunnel,”
NASA Ames Research Center, NASA TM 81927, 1981.
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