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Parallel Processing

 FLUENT can readily be run across many

Customer Training Material

processors in paraliel. This will greatly GURLUENIRL auncher EBIX
speed up the simulation time. ANSYS FLUENT Launcher
. . Direnszian Optionz
* It is common for modern generation ggg ij'ebP;jfignl
computers to have several processors, S ] Use Rermote Linus Nodes
and / or several compute ‘cores’ per o i R
processor. Each one of these can be a Embed Graphics Windons |
‘node’ for the FLUENT Slmulatlon workbench Color Scheme (#) Parallel [Local Maching]

Murnber of Processes

[==| Show Fewer Options

 The mesh is automatically partitioned, and Genera Opiors | ParalelSeings | Scheckier
different blocks of the mesh are assignedto ||
) nterconnects [] Cache HP-MPI Password
the different compute nodes. [cefou ]

WPl Types
|default A4 |

Environment

* Running FLUENT on a single machine with o Topes
multiple cores can simply be set by selecting | © swdmeny o ocaitactine
the ‘parallel’ option on startup (see image). .

* Alternatively a distributed parallel cluster can
be set up, and the simulation run across
many* machines simultaneously

* FLUENT scales well, and simulations using ok J [ Deat | [ Lol J [ Heb -
several hundred nodes are not unheard of.
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Solver Basics

FLUENT 13 GUI Navigation

« The FLUENT GUI is arranged such that the tasks are generally arranged
from top to bottom in the project setup tree.

NANSYS

Customer Training Material

 Selecting an item in the tree opens the relevant input items in the center

T General File Mesh Define Solve Adapt Surface Display Report Farallel View Help
G @[S AR S KA O-
roblem Sef G I
- M Od e I S P n,, tup Eeneral

= D;Fluid Flow (FLUENT) FLUENT [3d, pbns, lam] [ANSYS CFD]

= Mesh
Models
H Materials [ scale.. J[ ched ][Reportouaity]
M ate rl a | S Cell Zone Conditions

Boundary Conditions

Solver
Dynamic Mesh T Velodty Formulation
— B 0 u n d a r Reference Values é”f rrrrr Based (%) Absolute
Solution Obensity-Based  ORelative
L R Solution Methods
Solution Controls ==
Conditions B
Solution Initialization | |~ TeMSEN
Calculation Activities [ eravity
Run Calculation

— Solver Settings

Results

Graphics and Animations
Plots

Help

rE . . Reports
Mesh Mow 30, 2010
— Initialization and NS FLUENT 130 G
. Done . ~
CaICu Iatlon Preparing mesh for display...
Done.
Writing Settings file...
. writing rp variables ... Done.
— Postprocessin writing donain variahiss oo bone.
writing fluid (type fluid) (mixture) ... Done.
writing wall-fluid (type wall) (mixture) ... Done.
writing interior-fluid {(type interior) (mixture) ... Done.
writing inlet-y (type velocity-inlet) (mixture) ... Done.
writing inlet-z (type velocity-inlet) {(mixture) ... Done.
writing outlet (type pressure-outlet) (mixture) ... Done.
writing zones map name-id ... Done
v
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Mouse Functionality

Customer Training Material

* Mouse button functionality depends on the chosen solver (2D / 3D) and
can be configured in the solver.

 Default settings

Display—Mouse Buttons...

— 2D Solver & Mouse Buttons ['5__<|
* Left button translates/pans (dolly) LEft | mouse-ratate v
* Middle button zooms Middle [ o ee-z00m v
* Right button selects/probes RIGht | mouse-probe v

— 3D Solver Probe 15ng description —————
 Left button rotates about 2 axes

V4
[ FLUEMT Defaults (ll Workbench Defaultsp

* Middle button zooms

— Middle click on point in screen centers point | ok | [cancel| | Help |
in window

* Right button selects/probes

 Retrieve detailed flow field information at point with Probe enabled.
— Right-click on the graphics display.

« User can choose between classic ‘FLUENT’ settings, or for mouse
behaviour consistent with Workbench.

ANSYS, Inc. Proprietary Release 13.0

© 2010 ANSYS, Inc. All rights reserved. . December 2010



Solver Basics I\N SYS

Text User Interface

Customer Training Material

* Most GUI commands have a corresponding TUlI command.
— Press the Enter key to display the command set at the current level.
— g moves up one level.

— Some advanced R T CYICVA -k
commands are only == e

Madels

avai Ia b I e th ro u g h Materials [ Ds‘::::;..‘“ J[ check  J[Report quaity]

Cell Zone Conditions

th T l | I Boundary Conditions Salver
e " Dynamic Mesh Velodity Formulation
ite

=
Reference Values éD:'ESSUFEﬁESEd () absolu
() Density-Based () Relative

= D:Fluid Flow (FLUENT) FLUENT [3d, pbns, lam] [ANSYS CFD]

Salution

Solution Methods
Solution Controls

) Steady
Manitol
anars O Transient u \

Solution Initialization

Calculation Activities [ Gravity (units....]
Units. .

Run Calculation

Results Mash Mov 30, 2010

) ) AMSYS FLUENT 13.0 (3d, pbns, lam)
Graphics and Animations | (el g—

« The TUI offers many very | . .

valuable benefits: e
— Journal (text) files can TUl _| <
be constructed to Window e R S

dynamic-mesh/ models/ units
enable-mesh-morpher-optinizer? operating-conditions/ user-defined/

automate repetitive tasks.

— FLUENT can be run in :
batch mode, with TUI
journal scripts set to automate
the loading / modification / solver execution and postprocessing.

— Very complex models can be set using a spreadsheet to generate the TUlI commands.

/solver q
> define

/define>

=
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Sa m p I e F L U E N T J o u rn a I Customer Training Material

* A journal file is a text file which contains TUlI commands which FLUENT will
execute sequentially.

* Note that the FLUENT TUI accepts abbreviations of the commands for example,

— red Reads case and data files
— wed Writes case and data files

Sample Journal File

; Read case file

rc example.cas.gz

: Initialize the soelutioen
/solve/initialize/initialize-flow
; Caleculate 50 iterations

it 50

; Write data file

wd example50.dat.gz

; Calculate another 50 iterations
1t 50

; Write another data file

wd examplel00.dat.gz
; Exit FLUENT

exit

yes
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Scaling the Mesh and Selecting Units

« When FLUENT reads a mesh file
(.msh), all dimensions are
assumed to be in units of meters.

— If your model was not built in
meters, then it must be scaled.

— Always verify that the domain
extents are correct.

* When importing a mesh under
Workbench, the mesh does not
need to be scaled; however, the
units are set to the default MKS
system.

* Any “mixed” units system can be
used if desired.

— By default, FLUENT uses the SI
system of units (specifically, MKS
system).

— Any units can be specified in the

Set Units panel, accessed from
the top menu.
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& Scale Mesh

Domain Extents

min () 29,4923

min {mm} ‘ -31.99979

mm }|

wrnax {mrn | £0.53 (

fmaz {mm} | 31.99971

Zmin (mm) [ Zrnax (mm} |25.9??2
Wieww Length Unit In

Customer Training Material

Scaling

@' Convert Units
() Specify Scaling Factars

Mesh Was Created In

| I

o

\\/ |
[ Scale ] [ Unscals ]
& Set Units &|
CQuantities nits Set all ko
specific-heak Al |k
stefan-boltzmann-constant W default
surface-density r
surface-tension f E]
surFace-tensiDn-iradient
termperakture-inverse cgs
temper ature-difference Fachor | 1
thermal-conductivity
thermal-resistivity | Offset
thermophoretic-diffusivity | rls
kime b
[New...] [ Lisk ] [Clnse ] [ Help ]
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Polyhedral Mesh Conversion

* A tetrahedral or hybrid grid can be converted to
polyhedra in the FLUENT GUI (not in the
preprocessor).

— Generate a tetrahedral mesh then convert inside
FLUENT.
— Advantages
* Improved mesh quality.
« Can reduce cell count significantly.
» User has control of the conversion process.
— Disadvantages:
« Cannot be adapted or converted again.

« Cannot use tools such as smooth, swap, merge and
extrude to modify the mesh.

Customer Training Material

« Two conversion options are available in the
Mesh menu:
Mesh > Polyhedra > Convert Domain

— Convert all cells in the domain (except hex cells)
to polyhedra

« Cannot convert adaped meshes with hanging nodes |

— Convert only highly skewed cells to polyhedra

Mesh > Polyhedra > Convert Skewed
Cells
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- Material properties need to be defined for all fluids and solids to be simulated
« The parameters asked for will depend on the models selected for the simulation
« Many common materials are already defined in the ‘FLUENT Database’ and can

easily be copied  D:Fluid Flow (FLUENT) FLU SYS CFD]
over o the model T @@@M@MD

Problem Setup Materials
General | Materials
Model

aterial

Cell Zone Conditions aluminum

N Ote th at th ese Boundary Conditions Na!-ne S Orcer Materials by
Dynamic Mesh ” & | |ﬁ'-'i‘:| v | 8Name
H . Refe al Chemical Formula X . }MHK
values m ay be either: | &=~ [ [ (Game=))
Soluton et raiosinazheeerT]
« Constants
. Solution Initislization Properties
¢ F u n Ctl O n S Of :z::‘-(l.“l.aar:?.:lja:;:whes Bar=y gt constant b | Edit °
t t Reeults | T EEJDVbSD, 2|D1 1]
e m pe ra u re Graphics and Animations ‘ | +pans, lam)
. . . Flots Cp (Spedific Heat) (jfkg-k) tant R Edit A
« Other built in functions | === — ' |
following common Terma Conductty (W) (oo 3
. . 0.0242
relationships ~ o |
. = Ty (s constant » | Edit
* Defined by the user [ L
w
I n a U D F " [Changafcraabe] [ Delete ] [ Cloze ] [ Help ]
enable-mesh-morpher-optimizer? operating-conditions/ user-defined/
injections/ parameters/
fdefine> =
)
< >
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» The Operating Pressure with a Reference

Pressure Location sets the reference value that  ...cosew Boundary Conditions

is used in computing gauge pressures. e o -
Materials wall —
Phases wall-board-bottom

wall-chip-board
wall-chip-board-shadow

- The Operating Temperature sets the reference "o i |
. TAMIC Hes wall-chip-board:
temperature (used when computing buoyancy e xgnzimgzﬁzﬂd:Eéi-shadm
forces). Solutin Methods ol Rt
I_t"" Controls wall-chip-fluid: 024-shadaw

id:025

@& Operating Conditions E| d:025-shadow

Preszure Gravity

¢ S peCI.erd Operatl ng Operating Pressure (pascal) || [#] Gravity
De n S|ty SetS th e refe rence u 101325 | Gravitational Acceleration Type _ | I|D
. . % {mfs2)
value for flows with widely E

Reference Pressure Location

) ) 3 (in) || o | ¥ (mfsz) ” ey | B . =
va ryl n g d ens |ty . ¥ (in) || 5 | 2 (ris2) H - | h [C;:?ratlng Conditians. .. ]

Z (i) " o |

Boussinesq Parameters

Operating Temperature (k)
” 288.16 ‘

Variable-Density Parameters
Specified Operating Density
Operating Density (kgfm3)

u 1.225

[ (814 ] [Cancel] [Help ]
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COm p Uti n g th e So I Uti o n Customer Training Material

* The remaining steps are covered in the subsequent lectures
(and the practical workshops)

» Setting Boundary conditions (all outer boundaries to the fluid must be
prescribed - for example velocity inlet / pressure outlet / symmetry / wall)

» Solver Settings (optimising settings for speed, accuracy and stability)

- Initialisation (initial values for the flowfield)

 Solving the problem, and checking for convergence

* Postprocessing the results.
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Mesh Information and Hierarchy e
« All mesh information is stored in the mesh file.
— Node coordinates ¢ Node
— Connectivity Celllse
— Zone definition
Center
» Similar to the way geometry is defined, mesh Cell Face
entities obey a hierarchy:
— Node Edge intersection / grid point Eoundary
ace

— Edge Boundary of a face (defined by
two nodes Cell

— Face The boundaries of cells, defined by
a collection of edges

— Cell  The control volumes into which the Simple 2D Mesh
domain is discretized.

— Zone A collection of nodes, edges, faces S A A /]
or cells. y4 7 7

Z Z

» The computational domain is defined by all
members of the hierarchy

— For fluid flow simulation only, the domain consists only
of the fluid region.

— For conjugate heat transfer or fluid-structure
interaction problems, the domain needs to include any
solid parts that are present.

» Boundary data is assigned to face zones.

« Material data and source terms are assigned to cell
zones.

Simple 3D mesh

ANSYS, Inc. Proprietary Release 13.0
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Reordering and Modifying the Grid

Customer Training Material
* The grid can be reordered so that neighboring cells are near each other in

the zones and in memory
— Improves efficiency of memory access and reduces the bandwidth of the

computation
— Reordering can be performed for the entire domain or specific cell zones.
Mesh > Reorder > Domain Mesh > Reorder > Zones

— The bandwidth of each partition in the grid can be printed for reference.
Mesh > Reorder > Domain

* The face/cell zones can also be modified by the following operations in the
Grid menu:

— Separation and merge of zones

— Fusing of cell zones with merge of duplicate faces and nodes
— Translate, rotate, reflect face or cell zones

— Extrusion of face zones to extend the domain

— Replace a cell zone with another or delete it

— Activate and Deactivate cell zones

ANSYS, Inc. Proprietary Release 13.0
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Profile Data and Solution Data Interpolation

Customer Training Material

 FLUENT allows interpolation of selected SriteRefile
variable data on both face zones and cell Ogj:ﬁne N
zones by using profile files and data O viite Currertly Defined Profes
interpolation files, respectively. Sfoces B3 vales 26
- For example. a velosity profie from e B ﬁ
experimental data or previous FLUENT run at | |defautinterior:azo Absolte Pressure k
an inlet, or a solution interpolated from a e rass R Ty
coarse mesh to fine mesh. ety Al
File > Write > Profile %ﬁ%ﬁi b
symm-chip
020 Radial locky
File > Read > Profile v 2 Retatve yelochy Msgritude
Walbboard-botton Retatve  Valocty
wall-chip-board || |[Relative Z Yelocity bt
* Profile files are data files which contain point
data for selected variables on particular face e it
zones, and can be both written and read in a p—
FLUENT session. Otesdnd ot

File > Interpolate

Cell Zones

 Similarly, Interpolation data files contain
discrete data for selected field variables on
particular cell zones to be written and read
into FLUENT.

[Write...] [ Close ] [ Help ]
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