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1 INTRODUCTION 1

1 Introduction

LS-DYNAr is a finite element code released by Livermore Software Technology Corpo-

ration (LSTC) for transient dynamic analysis capable of simulating complex real world

problems. For solving coupled multi-physics and multi-stage problems, LS-DYNAr

provides solvers, like arbitrary Lagrangian Eulerian (ALE), coupled fluid dynamics

(CFD), smooth particle hydrodynamics (SPH), etc.

LS-DYNAr include a pre-processing and postprocessing environment for the analysis of

finite element models. It is used in a wide range of industries like automotive, aerospace

etc., and also is extensively used in academic and research institutions due to its capability

to address non-linear problems. The LS-PrePostr graphical user interface (GUI) is shown

in Fig. 1.1. Fig. 1.1 helps the user to get familiar with the icons.

Figure 1.1: Graphical user interface (GUI) of LS-PrePost

The complete finite element analysis (FEA) is done in three different stages, namely

preprocessing, analysis, and postprocessing, respectively. During preprocessing the

given physical problem is modeled to generate a keyword file (.k). In the second

stage, i.e. in analysis the modeled physical problem is solved numerically. The du-
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ration of the analysis depends on the complexity of the given problems. In the last

stage the results are evaluated by using a binary output database file (d3plot), see Fig. 1.2.

The general approach involved in solving physical problems by using LS-DYNAr are

mentioned below:

� Create finite element (FE) Model

� Choose Material Model and Properties

� Assign Material and Property

� Assign loads and boundary condition

� Specify control parameters

� Create ”.k” input file

� Solve the .k file in LS-DYNAr solver to get ”d3plot” output file

� Post process the d3plot file in LS-PrePostr

Figure 1.2: Different steps of complete LS-DYNAr finite element analysis
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1.1 Aim

The aim of this tutorial is to develop a step-by-step instructions for simulation of a welding

process with the FEA-program LS-PrePostr. The tutorial contain a simulation of a single-

pass gas metal arc welding, but we can use the same method to simulate multi-pass welding.



2 LS-PREPOST 4

2 LS-PrePost

In the preprocessing, we generate a FE model for a physical problem. There are two

methods to use LS-PrePostr. The first is by means of the graphical user interface (GUI).

The second is by means of keyword file. The keyword file is a text file, which builds a bridge

for communication between the preprocessor and the analysis. It contains a complete

description of the FE-model, like geometry, material properties, boundary condition, mesh,

etc. This tutorial is designed to describe the user both the GUI and the keyword file

approach.

2.1 Geometry

The first step in this simulation is to create and give the model the right geometrical

dimensions. Geometry module is used to build different parts of the model. For complex

structure we can divide the whole model into various parts and create each part using

geometry module. Later all the parts can be assembled together. Here, we have a simple

rectangular plate of dimension 300 × 60 × 6 mm. To create the plate geometry go to

Geometry → Solid → Box, see Fig. 2.1.

It is also possible to import an already existing model from a CAD program.

Figure 2.1: Selection of a solid box geometry
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In create Box window choose the method parameter and enter value of the coordinate

(x1, y1, z1) and (x2, y2, z2). At the bottom click Apply → Done, see Fig. 2.2. Instead of

the menu bar one can also use the shortcut in the right toolbar, see Fig. 1.1.

Figure 2.2: Geometry of the plate

2.2 Mesh

To create the mesh for the given plate we should use the following steps, see Fig. 2.3 and

Fig. 2.4:

1. In the menu bar, click FEM → Element and Mesh → Solid Mesher

2. Choose Operation: Meshing

3. Click Volume by closed faces

4. Enter element size

5. Click Try Meshing Automatically

6. At the bottom click Accept → Done

This will create the mesh as shown in Fig. 2.4.
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Figure 2.3: Selection of a solid mesher

Figure 2.4: Plate mesh

We can also create mesh by using Block Mesher. This give us freedom to choose the

number of elements in each direction manually. To create mesh by using Block Mesher
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we can use the following steps, see Fig. 2.5:

1. In the right toolbar select Element and Mesh → Block Mesher

2. Choose Operation: Create

3. Choose Type: Single Block

4. Choose eight different corner of the plate

5. Enter the number of elements in I (x-axis), J (y-axis) and K (z-axis) direction,

respectively

6. At the bottom click Create → Accept → Done

Figure 2.5: Dialog box for a Block mesher in LS-PrePostr

2.3 Welding simulation setup

For welding setup in LS-PrePostr we need to create weld and orientation paths as a beam

elements. The weld path defines the path of the moving heat source represented by a

local moving coordinate system. The weld path is composed of geometrical information

provided from the trajectories and the time information, initial time and velocity provided

from the process plan. To obtain a local coordinate system, two trajectories are required
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for each weld path: the weld line which describes the origin of the coordinate system and

the reference line which describes its orientation.

2.3.1 Weld line

To create a weld line we need to apply the following steps, see Fig. 2.6:

1. From the LS-PrePostr menu bar, select Geometry→ Curve→ Line. A sub menu

called ”Create Line Segment” will pop up.

2. In the Create Line Segment dialog box choose Parameters as the Method, see Fig.

2.7

3. Enter the coordinate of the Start Point

4. Enter the coordinate of the End Point

5. At the bottom of the dialog box click Apply and Close

Figure 2.6: Selection of the curve toolbar to create a line
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Figure 2.7: Geometry of the welding line

2.3.2 Beam element

By following the steps below we can create the beam element, see Fig. 2.8:

1. From the right toolbar, select FEM → Element and Mesh → Element

Generation. A sub menu ”Element Generation” will pop up.

2. In the Element Element Generation dialog box, select the option Beam

3. Element ID and Part ID will be automatically generated

4. Choose Beam by: Curve

5. Click the Third Node option and give the values for x, y and z

6. Choose the option Num and enter the value 1 in order to divide the weld line in

one beam element.

7. In the next step select the line by using your cursor

8. At Bottom of the dialog box, select Create → Accept → Done

9. In the Sel. genom window, choose the options Pick and add.
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Figure 2.8: Beam element creation

2.3.3 Reference line

In LS-PrePostr we need to define a orientation path as beam element to model heat

source. To create this reference line we can follow the same procedure as mentioned for

welding torch, see Fig. 2.9

Figure 2.9: To create reference line
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2.4 Weld and reference line path

To define the path of the moving heat source and its orientation, we can follow the steps

below, see Fig. 2.10 und Fig. 2.11.

1. From the right toolbar, select Model and Part → Create Entity

2. From the Entity Creation box, select Set Data → *SET NODE

3. Choose the option cre to create path for the weld line

4. Enter a title (This is optional).

5. From the Sel. Nodes dialog box, select pick and add.

6. Choose the nodes of interest along which the line will move

7. In the last step select Apply → Done from the Entity creation box

Figure 2.10: Path of the welding line
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Figure 2.11: Reference line path

2.5 Material Models for Welding Simulations

The keyword *MAT is used to define the properties of various materials used in the

model. Then, sections are created and materials are assigned to each section. For this

simulation we have used the material type 270 (*MAT CWM). It is a thermo-elasto-

plastic material model based on the Von Mises yield function with isotropic, kinematic

or mixed hardening. This material model allows the parameter to be defined as a function

of temperature, see Fig. 2.12. This serves as a very simplistic model for the phase change

in the microstructure.

The variables, LCEM, LCPR, LCAT, LCSY and LCHR, in Fig. 2.12 represents the

load curve for Young’s modulus, Poisson’s ratio, thermal expansion coefficient, yield

limit and hardening modulus as a function of temperature, respectively, see Fig. 2.13 -

2.17.

The material model *MAT UHS STEEL and *MAT PHS BMW are implemented for

detailed studies of the material properties in the heat affected zone. This material model

contains elaborate phase kinetics models and expect the input of the chemical composition

and the thermos-mechanical properties of the individual phases of the microstructure.
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Figure 2.12: Material property of the plate

Figure 2.13: Young’s modulus as a function of temperature

Figure 2.14: Poisson ratio as a function of temperature
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Figure 2.15: Thermal expansion coefficient as a function of temperature

Figure 2.16: Yield limit as a function of temperature
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Figure 2.17: Hardening modulus as a function of temperature

To define the thermal material property we should use the keyword

*MAT THERMAL CWM. It is a thermal material model with temperature

dependent properties, see Fig 2.18.

The variable, LCHC and LCTC, in fig. 2.18 represents specific heat- and thermal con-

ductivity as function of temperature, respectively, see Fig. 2.19 and Fig. 2.20.

Figure 2.18: Thermal property
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Figure 2.19: Specific heat as a function of temperature

Figure 2.20: Thermal conductivity as a function of temperature

2.6 Section

The keyword *SECTION is used to define the element formulation, integration rule,

nodal thickness and cross sectional properties.

2.6.1 Plate section

After the materials have been created we need to assign these materials to the parts which

were previously created. For this purpose we can use GUI as well as keyword file. To

assign the plate section with corresponding material we need a section identifier (SECID),

which must be unique and element formulation (ELFORM). Here, we have used the



2 LS-PREPOST 17

keyword *SECTION SOLID, which define section properties for solid continuum and

fluid elements, see Fig. 2.21.

Figure 2.21: Section plate

2.6.2 Beam section

To define cross sectional properties for beam we should use the keyword

*SECTION BEAM, see Fig. 2.22.

Figure 2.22: Section beam

2.7 Heat source

A weld heat source model by J. Goldak is used by LS-DYNA to model the weld heat

source. The Goldak weld heat source model is based on a Gaussian distribution of power

density in space. An important feature of this model is that it uses a double ellipsoidal

method of heat deposition such that the size and shape of the energy source can be

easily changed to account for different types of welds namely, arc welding, laser and beam

welding, and friction stir welding. The energy deposited in the front and rear quadrants

are defined by the fractions Ff and Fr. The weld shape parameters, a, b, cf, cr are defined

using *BOUNDARY THERMAL WELD keyword in input file, see Fig. 2.23.
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Figure 2.23: The Goldak weld heat source

2.8 Contact cable

To bring the weld line in contact with plate, we can use the keyword

*CONTACT GUIDE CABLE, see Fig. 2.24.

Figure 2.24: Contact

2.9 Heat source motion

The heat source movement like, translation and rotation, is defined by using the keyword

*BOUNDARY PRESCRIBED MOTION RIGID, see Fig. 2.25. .

Figure 2.25: Motion of the weld and reference line
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2.10 Weld line motion

The weld line is considered to be a rigid body and we can use the keyword *MAT RIGID

to define its material property, see Fig. 2.26.

Figure 2.26: Rigid body property for the weld line

2.11 Initial condition

To initialize a particular value we can use the keyword *INITIAL. To define initial nodal

point temperature we can use the keyword *INITIAL TEMPERATURE SET. These

initial temperatures are used in a thermal only analysis or a coupled thermal/structural

analysis. In Fig. 2.27 we have used the numerical value 0 for NSID. Here, 0 represents

that we have included all nodes. Instead of that we can also use particular set of nodes.

Figure 2.27: Initial condition

2.12 Thermal boundary condition

For a thermal analysis we need to apply a convection boundary condition

on a SEGMENT or SEGMENT SET. For this we can use the keyword

*BOUNDARY CONVECTION SET (This card is used to specify the convection

coefficients to a group of element segments), see Fig. 2.28.

The variable HLCID represents convection heat transfer coefficient, h.
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Figure 2.28: Thermal boundary condition

2.13 Curve

The keyword *DEFINE CURVE is used to define trajectory and reference line travel

distance, see Fig. 2.29.

Figure 2.29: Curve definition for weld and reference line
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2.14 Parameter

This option provides a way to specifying numerical values of parameter names that are

referenced throughout the input file. The parameter definitions, if used, should be placed

at the beginning of the input file following *KEYWORD. Here, we have assign numerical

values to time step and heat source velocity, see Fig. 2.30.

Figure 2.30: Parameter

2.15 Part group

By using the keyword *SET PART LIST we can create part set ID, which can be used

for Goldak double ellipsoid heat source, see Fig. 2.31.

Figure 2.31: Part Group

2.16 Implicit analysis

Thermal problems in LS-PrePostr are solved using implicit time integration. Therefore,

there is no stability condition on the thermal time step. Much larger time steps can be

used for the thermal solution as opposed to the mechanical solution, which uses explicit

time integration. For implicit analysis we need to use the following keywords, see Fig.

2.32 and Fig. 2.33:

*CONTROL SOLUTION: This card is used to specify the analysis solution procedure

if thermal only or coupled thermal analysis is performed.
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*CONTROL START: This keyword define the start time of analysis.

*CONTROL TERMINATION: Used to terminate the job.

*CONTROL IMPLICIT GENERAL: This keyword is necessary to activate implicit

analysis and define associated control parameters, like time step. This keyword is required

for all implicit analyses.

Figure 2.32: Solver for thermal analysis

*CONTROL IMPLICIT SOLUTION: This keyword is used to specify whether a

linear or nonlinear solution is desired.

*CONTROL IMPLICIT DYNAMICS: The purpose of this keyword is to activate

implicit dynamic analysis and define time integration constants.

*CONTROL IMPLICIT AUTO: This card is used to define parameters for automatic

time step control during implicit analysis.

*CONTROL THERMAL NONLINEAR: By using this keyword we can set param-

eters for a nonlinear thermal or coupled structural/thermal analysis.

*CONTROL THERMAL TIMESTEP: This card is used to define the timestep pa-

rameters for the thermal only analysis.
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Figure 2.33: Solver for implicit thermal analysis

2.17 Output file

The keyword *DATABASE with a combination of options is used for controlling the

output of ASCII databases and binary files output. With this keyword the frequency of

writing the various databases can be determined.

The keyword *DATABASE BINARY is necessary to obtain output files containing

results information, see Fig. 2.34. The keyword *DATABASE TPRINT gives thermal

ouput from a coupled structural/thermal or thermal only analysis.

The keyword *DATABASE BINARY is used for binary output option

and the attribute D3PLOT represent the database for entire model. If

*DATABASE BINARY D3PLOT is not specified in the keyword file then the
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output interval for d3plot is automatically set to 1/20th the termination time.

Figure 2.34: Binary output file

By using the keyword *DATABASE EXTENT BINARY we may control to some

extent the content of binary output databases.

Figure 2.35: Extended binary output file

3 Postprocessing

The results generated from the analysis can be enormous so it requires additional pro-

cessing which is termed postprocessing. LS-PrePostr GUI is used for postprocessor. It

supports the latest Open-GL standards to provide fast rendering for fringe plots and ani-

mation results. It also handles the ASCII output data and links it to the input files and

animations.

LS-PrePostr also include features like animations, contour plots, X-Y graphs, overlay

plots, vector plots, ASCII plotting, mesh manipulation, etc,.

3.1 Animation interface

The Animation controls are displayed when d3plots are loaded. If the animation interface

is closed, it can be restored by clicking the Anim render button, see Fig. 3.1.
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Figure 3.1: Animation interface

The results generated from the analysis can be viewed in LS-PrePostr, see Fig. 3.5:

1. From the right toolbar, select the Fringe component option

2. In the Fringe component dialog box, choose the option Misc

3. Choose the variable of your interest, here it is temperature

4. Use the animation interface, see Fig. 3.1, to animate the temperature field
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Figure 3.2: Animation interface

3.2 Plot

The temperature vs time plot can be created as shown in Fig. 3.4 - 3.5:

1. In the menu bar, select File → Open → LS−DYNA Binary Plot, see Fig. 3.3

2. From the right toolbar, click the ASCII option

3. Choose the option tprint* for temperature data

4. In the next step load the computed temperature data by clicking the option Load

5. Select the node at which you want to know the temperature distribution

6. Click the variable of interest, here temperature

7. At the bottom of the dialog box click the option Plot and this will generate the

temperature field vs time graph as shown inn Fig. 3.5.

Here, not all the modules of postprocessing are explained. One can explore different

modules and try to generate plots for different parameters and get meaningful results out

of them.
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Figure 3.3: Sub menu to open the binary file

Figure 3.4: ASCII dialog box
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Figure 3.5: Temperature vs time graph
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